Avatar Legends - Character Sheet partially non functioning

Hi! Love the character sheets, but I’m having a strange issue with one of my characters. I can’t perform certain basic functions on it, like marking fatigue, moving the balance track, etc. I can do other things, like mark growth, add statuses, and I can still operate all my other character sheets just fine, so I’m not sure what’s happening with this one. Any thoughts? Thank you!


Are you able to share your character with me?

If you load up your character, click on their picture, then on the drawer that opens, at the bottom of it, switch your share permissions to anyone with a link, and post a link to the character?

Also what devices/browser are you using?


Tried in both Firefox and Chrome, on a couple different PCs, with same results. Also just tried on Chrome on an android phone and had the same experience.

Thanks! It appears to be an issue with the state that character got into.

I have sent this on to the team to take a look at.

Oh no, did he try to enter the Avatar state without being the avatar? :joy: Thanks for the quick replies.

Hey timetravelertom,

We have gone ahead and fixed your character up, you should be good to go.

The team is still looking into how the character got into that state. Let me know if that happens to you again!

Thanks! Hopefully it won’t!