Can not add new items to my cart

Long story short, I bought the avatar legends starter pack and used the code to get the digital version.

now i want to buy the rest of the content of the game, but i’m unable to add ANYTHING to my cart when i’m signed in. i made my account by logging in with Google, which i suspected might be causing the problem so i made a new account without using “sign in with google” and i can add stuff to my cart just fine there.

the two adventures from the starter kit are already on my google-made account, so i can’t swap over to the newer account and just use that one, so is there any way to fix my original account so i can buy stuff on it?

Hi there! I’m sorry you’re encountering this issue. What browser are you using when the issue occurs?

Google chrome, i haven’t tried logging in on any other browser.

Update: i’ve tried it on 4 different browsers now, i’ve had the same problem on all of them

Thanks for the update. When you have a moment, could you please fill out a support ticket that includes your account username and the email address linked to your account so we can dig into the issue?