Character Builder Adding More Available Trained Skills at Level 1 When I Exit Out

I’m bad at titles so bear with me. Here’s what’s happening.
Ancestry Fetchling. Background Bandit. Class Swashbuckler. Level 15. Using free archetype rules with Acrobat archetype and also adding Fighter starting at level 12.
I’m rebuilding an old PC of mine from first edition so I’m starting at level 15. When I first started working on him I built out to level 3 and then I saved and left. His int is 10 so he had four skills to train at level 1. When I logged back in to work on him it showed me that I had trained 4 of 5 skills which was definitely odd but I just went with it, assuming I had done it wrong before. So I built out to level 14 or so and I noticed that when I was trying to train some of my skills past trained it was allowing me to apply the skill increases but the skills still showed trained. Odd but I assumed it was just a display bug and it’d clear up on the character sheet. Only when I saved and left for a while and came back, I was told that I had trained 5 of 11 skills at level 1. Now I know that’s for sure incorrect. In addition, the Fighter Dedication and Basic Maneuver feats I took at level 12 and 14 aren’t showing me that I added them and I can’t pick the fighter feat that Basic Maneuver gives you.

Thanks for reporting! I’d love to do a little digging into this, and I think the easiest way to dig into it would be for us to take a look at the character. Could you copy and share the string of numbers and letters at the end of that character’s url here? It’s everything after “/character-sheet/” in the url bar. Our team can then go in and look at what’s happening in the engines behind the scenes.

Additionally, if you could remind me what browser and operating system you’re using, that would be much appreciated, as there are a handful of browser-specific bugs that might be related here.

I’m using Windows 11 with Microsoft Edge, which is Chromium based. I’ll grab Chrome and see if the problem persists, and I can also take a look in Safari on my iPhone, iOS 16.5.
Update: Tried Chrome and my iPhone and the problem persists on both. Far as I can tell it’s probably something caused by a change that was implemented when open beta started, because I didn’t see anything like this in the closed alpha, although admittedly I didn’t ever try Swashbuckler.
The string of letters and numbers for the character is 8beea06c-5de9-4a63-99eb-366b29822d1c
Is that how Character Sharing is working for now? Here’s hoping for something a bit more intuitive in future.

Thanks for the info, I’ve passed it on to our team to take a look!

No, that is not how character sharing currently works, but it’s the specific information that our dev team needs to go look at the character in the backend. For character sharing, you can click on your character’s avatar, which pops out a window on the right side. At the bottom, you can change your sharing settings and copy the link to your sheet. Right now, you can only share for others to view or make it private, but eventually you’ll be able to share with specific users to give them editing privileges, much like in Google Drive.

I’ll update you when our team has news to report back about that bug. :slight_smile:

I ran into a similar problem in case this helps the team look into it. Character ID: f4606221-7740-4c32-b914-60d600e04584

In my case, choosing a skill would result in getting the “Expert” level. So I leveled it down to “Trained”, but that actually gave me the skill point back. So I now have a character that has five extra “Trained” skills, but I can still select five more skills. Selecting those skills will also still give me the “Expert” level.

Browser Info: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:109.0) Gecko/20100101 Firefox/114.0

I definitely recommend using the character tools in Chrome Or Edge. There are a ton of bugs when using it in Firefox, but your issue does sound similar to mine. I’d be interested to see if it still happens in Chrome.

I think I might have suppled a pond what is happening here when I went to make my own test character.

If I’m right than whenever you get an extra skill to add to your character, it counts it towards your level 1 skills instead of whatever class level the extra skill should have come in on at.

That does happen if you increase your intelligence, but in this case I did not do so. In any case, nothing would give me enough skill trainings to go from 4 to 11 by level 15. At least, nothing I picked should have done that.

Hello! Following up after the long weekend to get some additional details for the team. Previously I just asked for character IDs, but now for those of you who are experiencing issues with skill trainings, could I get you to go in and update your character sheet share settings to let anyone with the link view?

To do this: Click on your character’s portrait, which opens the character sheet settings sidebar. If you scroll all the way down past the themes in that sidebar, you’ll see a dropdown to change your share settings. Please set it to “Anyone with the link can view” and then please give me the URL for your character sheet.

We’re going to go in and make some copies of these characters for us to figure out what’s happening. :slight_smile:

Sure, it should be viewable now: f4606221-7740-4c32-b914-60d600e04584

I think the incorrect skill choice count is just a result of the skills being given as “Expert” instead of “Trained”. I am able to consistently do this in Firefox with a new level 1 character, but not in Chrome so it does seem like a browser-specific problem.

Thank you for looking into this! I know the team hasn’t had the time to fully test Firefox yet and I appreciate the work.

These may be multiple, but similar/related issues. When you view/build this character in Chrome, do you have too many skill selection options as well, or is that limited to Firefox?

Mine should be: (

I’m using a hp laptop with Intel inside, Windows 11 and Microsoft Edge.

Sorry for the delay. I updated my sharing preferences and here’s the link.

I’ve added your information to the ticket for our team to dig into. :slight_smile:

When you view/build this character in Chrome, do you have too many skill selection options as well, or is that limited to Firefox?

If I create a character in Firefox, grant 5 Expert skills, and level all 5 down to Trained, then the character will have 0/5 skill selections used despite having gained 5 Trained skills. If I then pull up that character in Chrome, the character will still show all 5 Trained skills and 0/5 skill selections.

If I create a character in Chrome, the 5 skills will be granted as Trained which means leveling the skills down removes the skill. So then the 0/5 skills selection is accurate because I’ve lost all 5 Trained skills.

There are known issues with Firefox and the builder right now. We recommend not using Firefox until those issues can be addressed.

Have you learned anything about this issue? I was using a chrome-based browser, and the more I added stuff at higher levels the more skill trainings he got at level 1. I haven’t checked in a couple days because I didn’t see anything about it in the changelog.

I don’t have an update on this yet, but I’ll keep you updated when more information is available. :slight_smile: