Character sheets unusable on Silk browser?

We just picked up a Kindle Fire HD 8 (newest version) mainly so we could use Demiplane on it at game nights.

Unfortunately, it seems impossible to use on the Silk browser. The blue Demiplane swirl spins and stops and spins some more and eventually stops completely, with nothing but a huge blank white space below it. The character sheet never loads.

Is anyone else successfully using Demiplane on a Kindle Fire tablet?

(Yes, I am aware it’s sometimes possible to sideload Google Play Services and Chrome on a KF if you do enough praying to the machine spirits, it’s not worth my time for a device this cheap.)

Thanks for letting us know! I don’t expect that Silk support is something we’ll focus on anytime soon, but it is good information to have.

In the meantime, if the process to set up Chrome on the device isn’t worth the work for you is it possible to use any other browser? I am not a Kindle user, so I don’t know what the options are, but that seems like the next step to try if Silk doesn’t work.

I have a Kindle Fire HD 10 (9th generation) and I do not have any trouble loading my characters. It does take a little bit of time to load.

if the process to set up Chrome on the device isn’t worth the work for you is it possible to use any other browser?

Not really. There are no other browsers on the Amazon app store. Amazon wants you to stay within their walled garden. That’s why sideloading Chrome is necessary to get it working, if it works at all.

We’re returning the tablet since this is one of like 2 things we needed it to do and it can’t do it, but I would venture to suggest you might not want to ignore these devices completely. Amazon’s tablets have the third-biggest share of the tablet market now after Apple and Samsung, they’re gaining on the latter, and they’re basically the only option for low-cost tablets unless you want to take your chances on the generic Android devices sold under such illustrious brand names as “TUOHAITIME” and “Relndoo.”

I have a Kindle Fire HD 10 (9th generation) and I do not have any trouble loading my characters. It does take a little bit of time to load.

I’ve sat and waited for up to 5 minutes without results.

Sorry to hear that, I’m not sure if they change any of the browser software since I got my tablet in 2021.
In your Silk settings, under Advance settings, then under Site settings does it have JavaScript Allowed? Just trying to do a little troubleshooting to help.

Our plan is to make it possible for gamers to use Demiplane on as many devices and browsers as possible, so you can rest easy knowing we have no plans to ignore Silk or Amazon’s tablets.

Right now, it’s a question of focus for us, and our primary focus is on character tools until those are done cooking. As we get closer to a full release of the character tools, browser support will become a much higher priority for us, because we’ll have a finished product to show off. :slight_smile:

Just as an experiment, I went to Best Buy and logged in to Demiplane on three different Android based tablets they had on display: another Kindle Fire HD 8, a Samsung Galaxy Tab A7 Lite, and a Lenovo M10 Plus. The Kindle was using Silk of course but the other two had Chrome.

Character sheets will not load on any of them. The Samsung came closest, managing to load a “Nameless Wanderer” sheet (not the sheet for the character I had selected) once for what that’s worth.

Yes, JavaScript was enabled.

So, this seems to not just be an issue with the Silk browser used on Kindle tablets. I assumed it was a Silk vs Chrome thing because Demiplane works on Chrome on my Android phone. However, Demiplane was unusable even on the tablets running Chrome.

I then walked over to the Chromebooks and tried Demiplane on one of those and it worked without issue.

I cannot account for the difference in function between Chrome on a phone, PC, or Chromebook versus on a tablet, but it is real.

We very much appreciate your investigation! We’ll take note and look into what options there are for addressing some of these issues.

No need to thank me. I hope that you can figure out what’s going on so other people can enjoy using Demiplane on these devices. Thanks for taking my report seriously.

It’s really strange to me because as far as I knew Chrome on an Android tablet and Chrome on an Android phone, assuming both devices were running a fairly modern version of Android OS, were essentially identical. (And I think Silk is Chromium-based as well.) It makes no sense to me that a site would work on one device and not another when both are using essentially the same browser and OS. And yet that is consistently what happens… My sample of four tablets isn’t scientific but it’s enough for me to be sure what happened with the first Kindle Fire isn’t a freak thing. Stranger still is the post from someone with a slightly older KF saying they have no issues.

I feel (personal observations only) things have gotten a little stranger with browser/OS compatibility over the years! I mostly use Apple ecosystem, for example, and even if I use Chrome, my Chrome on MacOS behaves quite different from the rest of the team’s Windows OS Chrome experience! So strange.