Daggerheart Character Sheet Not Loading

I’ve been having a problem the last few days where I can only load my sheet on my mobile device, but not the browser. I use Google Chrome on both my PC and my phone. For PC, the symbols keep spinning and spinning, but nothing ever loads. I even left the tab open for several hours once and nothing ever popped in.

Actually, we can expand that to I’m unable to make new characters at all, for the same reason - nothing is loading in. I’ve tried clearing my cache as well, wondering if that could be a fix, but it has done nothing.

Hi there MagnificentMC, welcome to Demiplane.

I’m unfortunately unable to reproduce the issue you’re experiencing. A couple things that may help:

  • Try logging into Demiplane using an incognito browser on Chrome on your PC. If it works in the incognito window, there may be a browser extension or browser setting that is impacting Demiplane’s ability to load the character tools.

  • Test another browser (such as Firefox, Safari, or Brave) on the same device you’re encountering the issue with. Does the issue persist? If it does not, the issue may be in Chrome settings.

Let me know how these tests turn out at your leisure. Hopefully we can get this sorted so you can get back to making characters!

Using other browsers and incognito did do the trick, but I also went through each of my settings that I could to see why it wouldn’t load anything, and so far no luck

If this worked in incognito and it’s not an extension:

If you clear your cache and local storage, I bet that will do the trick.

Before you do that tho, did you see any errors in your console by chance?

I am actually seeing quite a few errors in the console - some of it related to third party cookies, which I enabled and then that almost completely went away. The other errors I’m not sure about.