Issues/Suggestions Found Recreating Player's Characters

Hi there! I was testing out the open beta by recreating my player’s characters. These are the issues I ran into when I was creating them as well as some suggestions I thought about during the process.

  • Found creating a Magus:
    • Shocking Grasp - clicking the crit button doubles the dice and multiplies it by 2. Should only multiply it by 2 RAW. After further investigation this might be the case for any spell with a drop down menu.
    • Clicking cast on cantrips grays it out implying it is used up and can’t be used again. Doesn’t seem necessary
  • Found creating a Ranger:
    • Selecting precision hunter’s edge doesn’t seem to trigger that I selected anything. (Clicking the other two options worked as intended)
  • General Bugs:
    • Clicking filter doesn’t seem to ever do anything when trying to filter feats during character creation
    • Clicking the name arrows on the list of feats doesn’t do anything. I’m assuming it’s intended to sort them by name.
    • I have trouble recreating the steps but I frequently have issues with the search boxes not working as intended. I’ll search something and either it won’ update at all or I’ll randomly see what I’m searching for list 2-3 times.
  • Suggestions:
    • Ability to view the multiple attack penalties for attacks
    • Ability to update amount of an item (unless I just couldn’t figure out how to do this)
    • Allow ability to affix talismans to items
    • Ability to view item traits and see the details of those traits
    • Ability to manage animal companions and familiars (I’m aware this is under development currently)
    • Allow custom items (guessing this will be part of the homebrew updates)
    • Allow adding a spell to scrolls, wands, anything else that can hold spells (not just adding to notes)
    • Ability to click outside of opened sidebars to close them. Instead of just clicking the ‘X’.

Thanks so much for all of the reports and feedback!

Shocking Grasp: Has been fixed, and I’ll be taking a look at other spells to address the issue elsewhere over the next couple days.

Cantrip Greying Out: Noted and passed along!

Precision Ranger: Bug logged!

Filtering/Sorting: Filtering is not yet available, but will be coming later as we continue to progress the beta!

Search: Noted, thank you!

Suggestions: Most of what you’ve suggested is on the list as we continue development, but anything that isn’t will be passed along!

Thank you so much. :heart:

1 Like

Something else I noticed is when I select the Adopted Ancestry general feat I am unable to select an Ancestry currently. So the feat is unusable right now.