Pathfinder Nexus - 12/7 Release Notes - Tooltips!

Hello everyone!

We have released an update on Pathfinder Nexus that brings two new enhancements to the Digital Reader in Early Access - tooltips for spells, feats, backgrounds, and creatures, and side navigation on larger screens.

Tooltips on larger screens will display a floating card on hover to allow you to see game element details at a glance. Whether you are on desktop or mobile, tooltipped links can be clicked/tapped to open a sidebar drawer with full details about the linked game element. If you want that game element in a separate page or tab, you can go to the details page from the sidebar as well.

On desktop views, there is now a left side navigation for the Digital Reader. We will introduce ways to minimize or hide the bottom navigation bar (in all views) later in Early Access.

We’ll share more updates as they come, happy holidays!


On mobil, tool tips don’t do anything for me when tapped.

We’ll need a little more info to troubleshoot that - they are working for us on mobile.

What OS and browser are you using? Are you clicking a “game element” (spell, background, feat, etc.) or a normal link? Only game elements would open the details sidebar.

I’m also not seeing any tool tips, but I’m checking it on Firefox with a Mac.

I’ll make sure that we’re all on the same page about what a tooltip is - here’s an example from Chapter 2: Ancestries & Backgrounds from the Core Rulebook in the Dwarf entry:

In the “Dwarven Adventurers” callout box, some backgrounds are highlighted in orange with a dotted underline. Anything with a dotted underline is a tooltip. If you’re on a desktop view (like in the screenshot), you’ll see that card pop up on hovering over the word. You can also click that and pop out a right sidebar with that text. I’ll also edit the original post to have this screenshot to help clarify what they are.

This screenshot is on Firefox (on a PC), so if either of you are not seeing those backgrounds tooltipped in that section of the Digital Reader, then we’ll certainly want to investigate to make sure why you can’t.


I submitted a bug ticket. The only thing I didn’t include is what I’m clicking on. It was a spell. What specifically, I can’t say it was a bunch of them.

Android 11
Samsung internet browser

Edit: to clarify I’m talking about mobile. On my desktop they worked as intended.

For example none of those purple links are clickable.

Thanks for the report.

I am able to reproduce. It looks like this happens when viewing the book from the sidebar (library) while on mobile.

Are you able to confirm you are viewing the book via going to “my library” and not the “sources” section?

Yes. I’m so used to using my library on mobile I didn’t think of my sources. It does work as intended under my sources.

Okay, really nice. This will let me explore the spells directly from the “list” section. I particularly like the “view details” button that opens the content in a new tab. Very nicely done!

EDIT: I notice that some of the spells (again looking at the spell lists in the core rule book) tooltips don’t have a “click for more” info button. I am not sure whether that is intended. Also (and I am guessing this is a limitation of the browser rather than what you are doing) sometimes the tooltips are cutoff and I have to reposition the content to be able to actually see the “click here” text.

ANOTHER EDIT: Ok, I see that the “click for more” only populates if the text is greater than the space for the tooltip. I would recommend that you ALWAYS have the “click for more” so that we can place it to the right for reference. Anyway, great work.

A THIRD EDIT (HAHA): I guess this is turning into a user case study in how ppl discover things. I am sure you mentioned it, but I somehow did not realize that simply clicking on the link populates the sidebar. The behavior is great, once you understand that this is what will happen.

1 Like

Great - thanks for the help identifying that - we’ll get the My Library section tooltips working soon!

Weird. It’s working today! Must have been a cache issues.

Opening a monster tooltip inside a monster tooltip breaks for me on mobile (Android 10, Chrome).
“Breaks” means it doesn’t open the other monster and instead seems to distort the whole page for a second before snapping back to the original monster tooltip.

To reproduce:

  • Sources → Core Rulebook
  • Scroll down to the white dragon tooltip (maybe five pages or so, one of the first tooltips in the book)
  • Tap on the white dragon tooltip

→ tooltip for the white dragon opens

  • Scroll down to the black dragon tooltip
  • Tap on the black dragon tooltip

Note: spell tooltips from inside a monster tooltip seem to work

Thanks for sharing - we will take a look!

I tried to reproduce this on my Android Chrome but couldn’t. In the example you gave, I’m wondering if it is indeed opening the black dragon tooltip, but since the “description” text about Chromatic Dragons is the same between white and black dragons, it looks like it’s not going to a new one? That threw me for a loop the first few times, so I wanted to check.