Pathfinder Nexus App does not load

Demiplane is currently a blank page with My Group and Join Open Groups followed by empty bubbles. I can login to the demiplane forums just fine but I can’t seem to connect to the Nexus.

Are you still encountering this issue? Clearing cookies abs doing a hard refresh sometimes helps when something displays/loads incorrectly.

If that doesn’t fix it, please fill out a ticket here so our team can look into it:

Hi, yes I am still encountering this issue, even after refreshing all cookies and trying on multiple devices. This is frustrating because I wanted to buy the DM Guide through your platform but I simply can’t right now. I have filled a ticket yesterday and I hope it’s answered soon.
This is what I see when I try to login:

Clicking on login shows me the login page for a split second before returning to this.

Our team is looking into it. We’ll reach out as soon as we have an update!


Ironically I’m having the same issue. Thought it might be an account ban as I kept getting password not recognised message but get password reset email and can log onto forums. Clearing cookies and caches done and tried using different browser and OS. No joy there🙂

We’ll take a look into it. If you’d be willing to submit a support ticket as well, we’ll be able to link the two issues and hopefully resolve them both.

same issue here. game compendium cards won’t open up and it says I am not signed in even though I actually am (I can still access my purchased content). Here’s a video of the problems: pathfinder nexus problem - YouTube

For everyone encountering this, can you confirm that you have cleared your cache and performed a hard reload (different than a normal refresh)?

Instructions for this are here ( We believe based on what we’re seeing on our end that this might resolve the issue.

Just cleared cache and performed a hard refresh and the problem persists :frowning:

Thank you so much for sharing the same issue guys, I thought I was all alone on this I was going insane.

I can confirm I have tried everything including the hard refresh steps provided, no luck. Exactly the same issue as the video posted by regalraster.

Quick update: We are still working on this issue and have a couple people working on it, but haven’t been able to replicate it on our end yet. If you are having this issue and haven’t yet, please submit a ticket so we can work with you to troubleshoot and then share a fix as soon as we have one! :pray: :pray:

Sharing again for ease of access:

Have now followed instructions for hard reset and still no joy. Support ticket has now been submitted as per request.

1 Like

submitted support ticket as well.

1 Like

Just a quick update that our team is still working on this. I’m hopeful that we’ll have a more substantial update tomorrow. In the meantime, thank you to everyone who has been helping us track down the root cause with your tickets and assistance in troubleshooting. :slight_smile:

1 Like

Thank you for your constant replies and engagement with the community. As a Product Manager working with these kinds of products, I know how this must feel for the team, and I’m very happy you’re handling this the way you are.

1 Like

Good news! We have identified what we believe is the root cause of the issue and are currently working on a fix. Your help in this effort has been incredibly helpful! Our team is hard at work, but I’ll be sure to share another update tomorrow when I can.


This issue should be resolved! We’ll be going through support tickets to make sure everything is marked complete, so please take a moment and try logging in again if you previously could not. Thank you everyone for your help in troubleshooting, and please let us know that it’s working for you now! :slight_smile:

1 Like

I can confirm it’s now working. I think the fix did introduce a new “issue” tho, but it’s pretty minor: Once I am logged into the platform, I can’t click on the Forum or My Groups quick link at the top of the page. But this is pretty minor :slight_smile:

1 Like

We’ll take a look at that and see what we can figure out.

Would you try hard reloading and seeing if that resolves it?

It could be that something needs to refresh on your end since we rolled out the update.