Some display issues

Hi there folks! Amazing work on getting things to this stage, and I’m looking forward to watching this evolve.

I love the general feel and layout, and I’ll have some more thoughts I’m sure when I play around a bit more, but so far it’s looking pretty great.

I’d have had a few consistent issues, mostly in Safari on Mac (latest version of Safari and macOS) and on iPad (iPadOS 16.1.1), though a couple of them also appeared when I tried Chrome on the Mac.

  • The initial character creation screen takes a long time to load; it’s visible but dimmed, with the disclaimer message pop-up, but the Demiplane logo spinner is there for a long time.

  • Response time is pretty slow in general, but that’s to be expected at this early stage I would guess! Slowest responses are choosing ability boosts and other similar character choice buttons.

  • Each time I choose a main section of character creation - Ancestry, Background, Class - the display shows the initial Getting Started panel for a few seconds before loading the appropriate section, even when I was previously in a different section.

  • This one might be Safari only, but when choosing a class or going back to the class section, the options for the first eleven or twelve levels do not appear - there’s either a blank space where they should be, or only the part of the level shows up, usually the bit at right containing the number of options for that level shows up. Those levels, and even the later ones that are visible, are unable to be selected or viewed in the right panel. Sometimes none of the levels show up at all. This has been consistent across the Investigator, Ranger and Bard classes which I’ve tried so far. (See screenshot for iPad example.)

  • There have been multiple JavaScript errors in both browsers, including one that led to a full crash in Chrome.

Hope these are helpful in chasing down some bugs!

Thanks for sharing this! We haven’t done any work yet to get the builder ready for tablets or mobile, so that issue with levels not loading will likely be resolved when we get to that.

Everything else has been noted. :slight_smile:

Thanks Joshua! Note that the level options display error isn’t confined to the iPad - I also see it on Safari on the Mac. It’s a bit less consistent in terms of how many of the early levels don’t display, and sometimes they are briefly visible.

Here are a couple of screenshots showing the same problem with the same character, this time on Safari 16.1 on macOS 13.0.1. (I have a content blocker installed, but I whitelisted the Demiplane site to prevent any issues there.)

I figured I’d piggyback onto this display comment. With the scaling I use to see anything, the character interface only occupies about 2/3 of the screen, and appears cut off at the bottom.

Thanks for the clarification, and that additional feedback. We’ll take a look! :slight_smile:

1 Like

Thanks again Joshua!

I didn’t see the following issues listed on a skim through the forum, so here are a few more things I’ve noticed; still on macOS, but I’ve switched to Chrome 108.0.5359.124 for now.

  • When I have outstanding choices for a character’s levels, the number of remaining choices for the class displays correctly while viewing Class options, but incorrectly if I view the Ancestry, Background or Getting Started sections.
  • When viewing the list of Skill Feats at level 2, items are repeated in the list.
  • Clicking on the forward and backward buttons, or the numbered “page” buttons, to show other parts of the list does nothing.
  • In the list of Skill Feats, some appear to be other kinds of Feats.
  • If I click away to another section and then return to the Class section, I am unable to click on and display a choice I’ve not yet made. The general Class information is displayed.

Here’s some more specifics as an example from my level 3 Swashbuckler, Jean-Reynard. (Yes, he’s a catfolk with a fox name; I don’t own the book with Kitsune in it.)

While viewing the Skill Feats available at level 2 I see correctly next to Class that I have 3 choices yet to pick: one from level 2 (I’ve already chosen a Swashbuckler Feat), and two from level 3.

If I click on “Background” without choosing a Skill Feat, the number next to Class changes to 53. (At a guess, this might be the total number of available choices available at all levels?)

I that Skill Feats list at level 2, I see ten feats - Acrobatic Performer through Bargain Hunter - and then the list starts again from Acrobatic Performer. The repeated feats also include some not in the original ten - Adopted Ancestry and Armor Proficiency. Those are General Feats, not Skill Feats.

I am unable to see or select feats not displayed on the first page of the list, as the numbered page buttons, and back and forward buttons, move the position marker at the bottom of the list, but do not change which feats are displayed.

If I click the Ancestry section, and then return to the Class section, I’m unable to go back to the Skill Feat panel listed under Level 2. It’s visible in the list of options, but only the general info for the Swashbuckler Class is displayed.

See also the attached screenshots.